What’s Vulnerable › Vulnerabilities
CVE-2023-4839: WP Go Maps <= 9.0.32 - Authenticated (Administrator+) Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Go Maps for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in versions up to, and including, 9.0.32 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Affected products
- wpgmaps WP Go Maps (formerly WP Google Maps): before 9.0.33 — fixed in 9.0.33
How to fix
Upgrade to a fixed version: wpgmaps WP Go Maps (formerly WP Google Maps) 9.0.33. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3045434/wp-google-maps/trunk/legacy-core.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/208c5ed1-879f-45ea-833e-d2e54c4f063f?source=cve
- https://plugins.trac.wordpress.org/changeset/3045434/wp-google-maps/trunk/legacy-core.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/208c5ed1-879f-45ea-833e-d2e54c4f063f?source=cve
Get alerted when CVE-2023-4839 or the next vulnerability affects your stack