What’s Vulnerable › Vulnerabilities
CVE-2021-24383: WP Google Maps < 8.1.12 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Google Maps WordPress plugin before 8.1.12 did not sanitise, validate of escape the Map Name when output in the Map List of the admin dashboard, leading to an authenticated Stored Cross-Site Scripting issue
Affected products
- wpgmaps WP Go Maps (formerly WP Google Maps): before 8.1.12 — fixed in 8.1.12
How to fix
Upgrade to a fixed version: wpgmaps WP Go Maps (formerly WP Google Maps) 8.1.12. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/163261/WordPress-WP-Google-Maps-8.1.11-Cross-Site-Scripting.html
- https://wpscan.com/vulnerability/1270588c-53fe-447e-b83c-1b877dc7a954
- http://packetstormsecurity.com/files/163261/WordPress-WP-Google-Maps-8.1.11-Cross-Site-Scripting.html
- https://wpscan.com/vulnerability/1270588c-53fe-447e-b83c-1b877dc7a954
Get alerted when CVE-2021-24383 or the next vulnerability affects your stack