What’s Vulnerable › Vulnerabilities
CVE-2019-14792
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Google Maps plugin before 7.11.35 for WordPress allows XSS via the wp-admin/ rectangle_name or rectangle_opacity parameter.
Affected products
- wpgmaps WP Go Maps (formerly WP Google Maps): before 7.11.35 — fixed in 7.11.35
How to fix
Upgrade to a fixed version: wpgmaps WP Go Maps (formerly WP Google Maps) 7.11.35. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/wp-google-maps/#developers
- https://wpvulndb.com/vulnerabilities/9442
- https://www.pluginvulnerabilities.com/2019/07/08/recently-closed-wordpress-plugin-with-400000-installs-contains-another-authenticated-persistent-xss-vulnerability/
- https://wordpress.org/plugins/wp-google-maps/#developers
- https://wpvulndb.com/vulnerabilities/9442
- https://www.pluginvulnerabilities.com/2019/07/08/recently-closed-wordpress-plugin-with-400000-installs-contains-another-authenticated-persistent-xss-vulnerability/
Get alerted when CVE-2019-14792 or the next vulnerability affects your stack