What’s Vulnerable › Vulnerabilities
CVE-2024-29931: WordPress WP Go Maps plugin <= 9.0.29 - Reflected Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPGMaps WP Go Maps wp-google-maps.This issue affects WP Go Maps: from n/a through <= 9.0.29.
Affected products
- wpgmaps WP Go Maps (formerly WP Google Maps): before 9.0.30 — fixed in 9.0.30
How to fix
Upgrade to a fixed version: wpgmaps WP Go Maps (formerly WP Google Maps) 9.0.30. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/wp-google-maps/vulnerability/wordpress-wp-go-maps-plugin-9-0-29-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wp-google-maps/wordpress-wp-go-maps-plugin-9-0-29-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-29931 or the next vulnerability affects your stack