What’s Vulnerable › Vulnerabilities
CVE-2019-14314
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 43.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-27 · updated 2026-06-17
- Weakness: CWE-89
Description
A SQL injection vulnerability exists in the Imagely NextGEN Gallery plugin before 3.2.11 for WordPress. Successful exploitation of this vulnerability would allow a remote attacker to execute arbitrary SQL commands on the affected system via modules/nextgen_gallery_display/package.module.nextgen_gallery_display.php.
Affected products
- Photo Gallery, Sliders, Proofing and Themes: before 3.2.10 — fixed in 3.2.10
How to fix
Upgrade to a fixed version: Photo Gallery, Sliders, Proofing and Themes 3.2.10. Check the vendor advisory for mitigations.
References
- https://de.wordpress.org/plugins/nextgen-gallery/#developers
- https://wordpress.org/plugins/nextgen-gallery/#developers
- https://wpvulndb.com/vulnerabilities/9816
- https://de.wordpress.org/plugins/nextgen-gallery/#developers
- https://wordpress.org/plugins/nextgen-gallery/#developers
- https://wpvulndb.com/vulnerabilities/9816
Get alerted when CVE-2019-14314 or the next vulnerability affects your stack