What’s Vulnerable › Vulnerabilities

CVE-2019-25142: Mesmerize <= 1.6.89 & Materialis <= 1.0.172 - Authenticated Arbitrary Options Update

Description

The Mesmerize & Materialis themes for WordPress are vulnerable to authenticated options change in versions up to, and including,1.6.89 (Mesmerize) and 1.0.172 (Materialis). This is due to 'companion_disable_popup' function only checking the nonce while sending user input to the 'update_option' function. This makes it possible for authenticated attackers to change otherwise restricted options.

Affected products

How to fix

Upgrade to a fixed version: extendthemes Materialis 1.0.173; extendthemes Mesmerize 1.6.90. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-25142 or the next vulnerability affects your stack