What’s Vulnerable › Vulnerabilities
CVE-2020-35943
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-09 · updated 2026-06-17
- Weakness: CWE-352
Description
A Cross-Site Request Forgery (CSRF) issue in the NextGEN Gallery plugin before 3.5.0 for WordPress allows File Upload. (It is possible to bypass CSRF protection by simply not including a nonce parameter.)
Affected products
- Photo Gallery, Sliders, Proofing and Themes: before 3.5.0 — fixed in 3.5.0
How to fix
Upgrade to a fixed version: Photo Gallery, Sliders, Proofing and Themes 3.5.0. Check the vendor advisory for mitigations.
References
- https://www.wordfence.com/blog/2021/02/severe-vulnerabilities-patched-in-nextgen-gallery-affect-over-800000-wordpress-sites/
- https://www.wordfence.com/blog/2021/02/severe-vulnerabilities-patched-in-nextgen-gallery-affect-over-800000-wordpress-sites/
Get alerted when CVE-2020-35943 or the next vulnerability affects your stack