What’s Vulnerable › Vulnerabilities
CVE-2021-24136: Testimonials Widget < 4.0.0 - Multiple Authenticated Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Unvalidated input and lack of output encoding in the Testimonials Widget WordPress plugin, versions before 4.0.0, lead to multiple Cross-Site Scripting vulnerabilities, allowing remote attackers to inject arbitrary JavaScript code or HTML via the below parameters: - Author - Job Title - Location - Company - Email - URL
Affected products
- Testimonials Widget: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: Testimonials Widget 4.0.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/537ee410-3833-4e88-9d4a-ee3c72b44ca1
- https://wpscan.com/vulnerability/537ee410-3833-4e88-9d4a-ee3c72b44ca1
Get alerted when CVE-2021-24136 or the next vulnerability affects your stack