What’s Vulnerable › Vulnerabilities
CVE-2021-24151: WP Editor < 1.2.7 - Authenticated SQL injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-89
Description
The WP Editor WordPress plugin before 1.2.7 did not sanitise or validate its setting fields leading to an authenticated (admin+) blind SQL injection issue via an arbitrary parameter when making a request to save the settings.
Affected products
- benjaminprojas WP Editor: before 1.2.7 — fixed in 1.2.7
How to fix
Upgrade to a fixed version: benjaminprojas WP Editor 1.2.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5ee77dd7-5a73-4d4e-8038-23e6e763e20c/
- https://wpscan.com/vulnerability/5ee77dd7-5a73-4d4e-8038-23e6e763e20c/
Get alerted when CVE-2021-24151 or the next vulnerability affects your stack