What’s Vulnerable › Vulnerabilities
CVE-2021-24160: Responsive Menu 4.0.0 - 4.0.3 - Authenticated Arbitrary File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-05 · updated 2026-06-17
- Weakness: CWE-434
Description
In the Reponsive Menu (free and Pro) WordPress plugins before 4.0.4, subscribers could upload zip archives containing malicious PHP files that would get extracted to the /rmp-menu/ directory. These files could then be accessed via the front end of the site to trigger remote code execution and ultimately allow an attacker to execute commands to further infect a WordPress site.
Affected products
- ExpressTech Responsive Menu (WordPress plugin): before 4.0.4 — fixed in 4.0.4
How to fix
Upgrade to a fixed version: ExpressTech Responsive Menu (WordPress plugin) 4.0.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/066ba5d4-4aaa-4462-b106-500c1f291c37
- https://www.wordfence.com/blog/2021/02/multiple-vulnerabilities-patched-in-responsive-menu-plugin/
- https://wpscan.com/vulnerability/066ba5d4-4aaa-4462-b106-500c1f291c37
- https://www.wordfence.com/blog/2021/02/multiple-vulnerabilities-patched-in-responsive-menu-plugin/
Get alerted when CVE-2021-24160 or the next vulnerability affects your stack