What’s Vulnerable › Vulnerabilities
CVE-2021-24257: Premium Addons for Elementor < 4.2.8 - Contributor+ Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The “Premium Addons for Elementor” WordPress Plugin before 4.2.8 has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
Affected products
- leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets: before 4.2.8 — fixed in 4.2.8
How to fix
Upgrade to a fixed version: leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets 4.2.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4ad8314e-1cbe-4642-b4ee-aac2060f9a25
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
- https://wpscan.com/vulnerability/4ad8314e-1cbe-4642-b4ee-aac2060f9a25
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
Get alerted when CVE-2021-24257 or the next vulnerability affects your stack