What’s Vulnerable › Vulnerabilities
CVE-2021-24293: NextGEN Gallery Pro < 3.1.11 - Reflected Cross-Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-05 · updated 2026-06-17
- Weakness: CWE-79
Description
In the eCommerce module of the NextGEN Gallery Pro WordPress plugin before 3.1.11, there is an action to call get_cart_items via photocrati_ajax , after that the settings[shipping_address][name] is able to inject malicious javascript.
Affected products
- Photo Gallery, Sliders, Proofing and Themes: before 3.1.11 — fixed in 3.1.11
How to fix
Upgrade to a fixed version: Photo Gallery, Sliders, Proofing and Themes 3.1.11. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5e1a4725-3d20-44b0-8a35-bbf4263957f7
- https://www.imagely.com/wordpress-gallery-plugin/nextgen-pro/changelog/
- https://wpscan.com/vulnerability/5e1a4725-3d20-44b0-8a35-bbf4263957f7
- https://www.imagely.com/wordpress-gallery-plugin/nextgen-pro/changelog/
Get alerted when CVE-2021-24293 or the next vulnerability affects your stack