What’s Vulnerable › Vulnerabilities
CVE-2021-24313: WP Prayer < 1.6.2 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Prayer WordPress plugin before 1.6.2 provides the functionality to store requested prayers/praises and list them on a WordPress website. These stored prayer/praise requests can be listed by using the WP Prayer engine. An authenticated WordPress user with any role can fill in the form to request a prayer. The form to request prayers or praises have several fields. The 'prayer request' and 'praise request' fields do not use proper input validation and can be used to store XSS payloads.
Affected products
- WP Prayer: before 1.6.2 — fixed in 1.6.2
How to fix
Upgrade to a fixed version: WP Prayer 1.6.2. Check the vendor advisory for mitigations.
References
- https://bastijnouwendijk.com/cve-2021-24313/
- https://wpscan.com/vulnerability/c7ab736d-27c4-4ec5-9681-a3f0dda86586
- https://bastijnouwendijk.com/cve-2021-24313/
- https://wpscan.com/vulnerability/c7ab736d-27c4-4ec5-9681-a3f0dda86586
Get alerted when CVE-2021-24313 or the next vulnerability affects your stack