What’s Vulnerable › Vulnerabilities
CVE-2021-24357: FooGallery < 2.0.35 - Authenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-14 · updated 2026-06-17
- Weakness: CWE-79
Description
In the Best Image Gallery & Responsive Photo Gallery – FooGallery WordPress plugin before 2.0.35, the Custom CSS field of each gallery is not properly sanitised or validated before being being output in the page where the gallery is embed, leading to a stored Cross-Site Scripting issue.
Affected products
- fooplugins Gallery by FooGallery: before 2.0.35 — fixed in 2.0.35
How to fix
Upgrade to a fixed version: fooplugins Gallery by FooGallery 2.0.35. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/950f46ae-4476-4969-863a-0e55752953b3
- https://wpscan.com/vulnerability/950f46ae-4476-4969-863a-0e55752953b3
Get alerted when CVE-2021-24357 or the next vulnerability affects your stack