What’s Vulnerable › Products
fooplugins Gallery by FooGallery vulnerabilities
20 known vulnerabilities, 0 confirmed exploited in the wild (CISA KEV), 8 published in the last 12 months.
Check whether your fooplugins Gallery by FooGallery version is affected
Latest fooplugins Gallery by FooGallery vulnerabilities
- CVE-2024-13362 — Freemius <= 2.10.1 - Reflected DOM-Based Cross-Site Scripting via url Parameter (CVSS 6.1)
- CVE-2026-25363 — WordPress FooGallery plugin <= 3.1.11 - Broken Access Control vulnerability (CVSS 4.3)
- CVE-2026-25362 — WordPress FooGallery plugin <= 3.1.11 - Cross Site Scripting (XSS) vulnerability (CVSS 5.9)
- CVE-2025-15524 — Gallery by FooGallery <= 3.1.9 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Gallery Metadata Exposure (CVSS 4.3)
- CVE-2025-6068 — FooGallery – Responsive Photo Gallery, Image Viewer, Justified, Masonry & Carousel <= 2.4.31 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting (CVSS 5.4)
- CVE-2024-12119 — FooGallery – Responsive Photo Gallery, Image Viewer, Justified, Masonry & Carousel <= 2.4.29 - Authenticated (Custom+) Stored Cross-Site Scripting via Album Title Size (CVSS 5.4)
- CVE-2024-12114 — FooGallery – Responsive Photo Gallery, Image Viewer, Justified, Masonry & Carousel <= 2.4.29 - Insecure Direct Object Reference to Authenticated (Custom+) Arbitrary Post/Page Updates (CVSS 4.3)
- CVE-2023-6947 — Best WordPress Gallery Plugin – FooGallery <= 2.4.16 - Authenticated (Contributor+) Directory Traversal (CVSS 7.7)
- CVE-2022-4974 — Freemius SDK <= 2.4.2 - Missing Authorization Checks (CVSS 6.3)
- CVE-2024-2122 — FooGallery <= 2.4.15 - Authenticated (Contributor+) Stored Cross-Site Scripting via Gallery Custom URL (CVSS 5.4)
- CVE-2024-2762 — FooGallery < 2.4.15 - Author+ Stored XSS (CVSS 5.4)
- CVE-2024-2081 — FooGallery <= 2.4.14 - Authenticated (Author+) Stored Cross-Site Scripting (CVSS 5.4)
- CVE-2024-2471 — FooGallery <= 2.4.14 - Authenticated (Author+) Stored Cross-Site Scripting via Image Attachment Fields (CVSS 5.4)
- CVE-2024-0604 — Best WordPress Gallery Plugin – FooGallery <= 2.4.7 -Authenticated(Administrator+) Stored Cross-Site Scripting via settings (CVSS 4.8)
- CVE-2023-6747 — FooGallery Premium <= 2.3.3 - Authenticated (Contributor+) Stored Cross-Site Scripting (CVSS 5.4)
- CVE-2023-44233 — WordPress FooGallery Plugin <= 2.2.44 is vulnerable to Cross Site Request Forgery (CSRF) (CVSS 8.8)
- CVE-2023-44244 — WordPress FooGallery Plugin <= 2.2.44 is vulnerable to Cross Site Scripting (XSS) (CVSS 6.1)
- CVE-2023-29439 — WordPress FooGallery Plugin <= 2.2.35 is vulnerable to Cross Site Scripting (XSS) (CVSS 6.1)
- CVE-2021-24357 — FooGallery < 2.0.35 - Authenticated Stored Cross-Site Scripting (CVSS 5.4)
- CVE-2019-20182 — (CVSS 4.8)