What’s Vulnerable › Vulnerabilities
CVE-2024-2762: FooGallery < 2.4.15 - Author+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The FooGallery WordPress plugin before 2.4.15, foogallery-premium WordPress plugin before 2.4.15 does not validate and escape some of its Gallery settings before outputting them back in the page, which could allow users with a role as low as Author to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admin
Affected products
- fooplugins Gallery by FooGallery: before 2.4.15 — fixed in 2.4.15
How to fix
Upgrade to a fixed version: fooplugins Gallery by FooGallery 2.4.15. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/92e0f5ca-0184-4e9c-b01a-7656e05dce69/
- https://wpscan.com/vulnerability/92e0f5ca-0184-4e9c-b01a-7656e05dce69/
Get alerted when CVE-2024-2762 or the next vulnerability affects your stack