What’s Vulnerable › Vulnerabilities
CVE-2021-24421: WP JobSearch < 1.7.4 - Authenticated Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP JobSearch WordPress plugin before 1.7.4 did not sanitise or escape multiple of its parameters from the my-resume page before outputting them in the page, allowing low privilege users to use JavaScript payloads in them and leading to a Stored Cross-Site Scripting issue
Affected products
- eyecix JobSearch: before 1.7.4 — fixed in 1.7.4
How to fix
Upgrade to a fixed version: eyecix JobSearch 1.7.4. Check the vendor advisory for mitigations.
References
- https://m0ze.ru/vulnerability/%5B2021-05-19%5D-%5BWordPress%5D-%5BCWE-79%5D-WP-JobSearch-WordPress-Plugin-v1.7.3.txt
- https://wpscan.com/vulnerability/b378d36d-66d9-4373-a628-e379e4766375
- https://m0ze.ru/vulnerability/%5B2021-05-19%5D-%5BWordPress%5D-%5BCWE-79%5D-WP-JobSearch-WordPress-Plugin-v1.7.3.txt
- https://wpscan.com/vulnerability/b378d36d-66d9-4373-a628-e379e4766375
Get alerted when CVE-2021-24421 or the next vulnerability affects your stack