What’s Vulnerable › Vulnerabilities
CVE-2021-24458: Popup box < 2.3.4 - Authenticated Blind SQL Injections
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-02 · updated 2026-06-17
- Weakness: CWE-89
Description
The get_ays_popupboxes() and get_popup_categories() functions of the Popup box WordPress plugin before 2.3.4 did not use whitelist or validate the orderby parameter before using it in SQL statements passed to the get_results() DB calls, leading to SQL injection issues in the admin dashboard
Affected products
- Ays Pro Popup box: before 2.3.4 — fixed in 2.3.4
How to fix
Upgrade to a fixed version: Ays Pro Popup box 2.3.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8a588266-54cd-4779-adcf-f9b9e226c297
- https://wpscan.com/vulnerability/8a588266-54cd-4779-adcf-f9b9e226c297
Get alerted when CVE-2021-24458 or the next vulnerability affects your stack