What’s Vulnerable › Vulnerabilities
CVE-2021-24459: Survey Maker < 1.5.6 - Authenticated Blind SQL Injections
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-02 · updated 2026-06-17
- Weakness: CWE-89
Description
The get_results() and get_items() functions in the Survey Maker WordPress plugin before 1.5.6 did not use whitelist or validate the orderby parameter before using it in SQL statements passed to the get_results() DB calls, leading to SQL injection issues in the admin dashboard
Affected products
- Ays Pro Survey Maker: before 1.5.6 — fixed in 1.5.6
How to fix
Upgrade to a fixed version: Ays Pro Survey Maker 1.5.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3fafbec0-55e4-41cf-8402-1b57b6615225
- https://wpscan.com/vulnerability/3fafbec0-55e4-41cf-8402-1b57b6615225
Get alerted when CVE-2021-24459 or the next vulnerability affects your stack