What’s Vulnerable › Vulnerabilities
CVE-2021-24958: Meks Easy Photo Feed Widget < 1.2.4 - Subscriber+ Settings Update to Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Meks Easy Photo Feed Widget WordPress plugin before 1.2.4 does not have capability and CSRF checks in the meks_save_business_selected_account AJAX action, available to any authenticated user, and does not escape some of the settings. As a result, any authenticated user, such as subscriber could update the plugin's settings and put Cross-Site Scripting payloads in them
Affected products
- Meks Easy Photo Feed Widget: before 1.2.4 — fixed in 1.2.4
How to fix
Upgrade to a fixed version: Meks Easy Photo Feed Widget 1.2.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/011c2519-fd84-4c95-b8b8-23654af59d70
- https://wpscan.com/vulnerability/011c2519-fd84-4c95-b8b8-23654af59d70
Get alerted when CVE-2021-24958 or the next vulnerability affects your stack