What’s Vulnerable › Vulnerabilities
CVE-2021-25011: WP Google Map < 1.8.1 - Subscriber+ Arbitrary Post Deletion and Plugin's Settings Update
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-862
Description
The Maps Plugin using Google Maps for WordPress plugin before 1.8.1 does not have proper authorisation and CSRF in most of its AJAX actions, which could allow any authenticated users, such as subscriber to delete arbitrary posts and update the plugin's settings.
Affected products
- Maps Plugin using Google Maps for WordPress – WP Google Map: before 1.8.1 — fixed in 1.8.1
How to fix
Upgrade to a fixed version: Maps Plugin using Google Maps for WordPress – WP Google Map 1.8.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2641450
- https://wpscan.com/vulnerability/6639da0d-6d29-46c1-a3cc-5e5626305833
- https://plugins.trac.wordpress.org/changeset/2641450
- https://wpscan.com/vulnerability/6639da0d-6d29-46c1-a3cc-5e5626305833
Get alerted when CVE-2021-25011 or the next vulnerability affects your stack