What’s Vulnerable › Vulnerabilities
CVE-2021-25045: Asgaros Forum < 1.15.15 - Admin+ SQL Injection via forum_id
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-24 · updated 2026-06-17
- Weakness: CWE-89
Description
The Asgaros Forum WordPress plugin before 1.15.15 does not validate or escape the forum_id parameter before using it in a SQL statement when editing a forum, leading to an SQL injection issue
Affected products
- Asgaros Forum: before 1.15.15 — fixed in 1.15.15
How to fix
Upgrade to a fixed version: Asgaros Forum 1.15.15. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2642215
- https://wpscan.com/vulnerability/c60a3d40-449c-4c84-8d13-68c04267c1d7
- https://plugins.trac.wordpress.org/changeset/2642215
- https://wpscan.com/vulnerability/c60a3d40-449c-4c84-8d13-68c04267c1d7
Get alerted when CVE-2021-25045 or the next vulnerability affects your stack