What’s Vulnerable › Vulnerabilities
CVE-2021-25081: WP Google Map < 1.8.4 - Arbitrary Post Deletion and Plugin's Settings Update via CSRF
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-352
Description
The Maps Plugin using Google Maps for WordPress plugin before 1.8.4 does not have CSRF checks in most of its AJAX actions, which could allow attackers to make logged in admins delete arbitrary posts and update the plugin's settings via a CSRF attack
Affected products
- Maps Plugin using Google Maps for WordPress – WP Google Map: before 1.8.4 — fixed in 1.8.4
How to fix
Upgrade to a fixed version: Maps Plugin using Google Maps for WordPress – WP Google Map 1.8.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2667376
- https://wpscan.com/vulnerability/f85cf258-1c2f-444e-91e5-b1fc55880f0e
- https://plugins.trac.wordpress.org/changeset/2667376
- https://wpscan.com/vulnerability/f85cf258-1c2f-444e-91e5-b1fc55880f0e
Get alerted when CVE-2021-25081 or the next vulnerability affects your stack