What’s Vulnerable › Vulnerabilities
CVE-2021-34193
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-22 · updated 2026-06-17
- Weakness: CWE-787
Description
Stack overflow vulnerability in OpenSC smart card middleware before 0.23 via crafted responses to APDUs.
Affected products
- OpenSC: before 0.22.0 — fixed in 0.22.0
How to fix
Upgrade to a fixed version: OpenSC 0.22.0. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=27719
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=28185
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=28383
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=28768
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=28843
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=28855
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=29912
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=30112
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=30800
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=31448
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=31540
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=32149
Get alerted when CVE-2021-34193 or the next vulnerability affects your stack