What’s Vulnerable › Products
OpenSC vulnerabilities
51 known vulnerabilities, 0 confirmed exploited in the wild (CISA KEV), 7 published in the last 12 months.
Check whether your OpenSC version is affected
Latest OpenSC vulnerabilities
- CVE-2026-40528 — OpenSC < 0.27.0 Buffer Overrun in do_key_value() via profile.c (CVSS 7.8)
- CVE-2026-40510 — OpenSC < 0.27.0-rc1 Stack Buffer Overflow via piv_process_history() in card-piv.c (CVSS 6.8)
- CVE-2025-13763 — Libopensc: opensc: multiple uses of uninitialized variable (CVSS 5.7)
- CVE-2025-66215 — OpenSC: Stack-buffer-overflow WRITE in card-oberthur (CVSS 6.8)
- CVE-2025-66038 — OpenSC: `sc_compacttlv_find_tag` can return out-of-bounds pointers (CVSS 6.8)
- CVE-2025-66037 — OpenSC: Out of Bounds vulnerability (CVSS 6.8)
- CVE-2025-49010 — OpenSC: Stack-buffer-overflow WRITE in GET RESPONSE (CVSS 6.8)
- CVE-2024-8443 — Libopensc: heap buffer overflow in openpgp driver when generating key (CVSS 2.9)
- CVE-2024-45620 — Libopensc: incorrect handling of the length of buffers or files in pkcs15init (CVSS 3.9)
- CVE-2024-45619 — Libopensc: incorrect handling length of buffers or files in libopensc (CVSS 4.3)
- CVE-2024-45618 — Libopensc: uninitialized values after incorrect or missing checking return values of functions in pkcs15init (CVSS 3.9)
- CVE-2024-45617 — Libopensc: uninitialized values after incorrect or missing checking return values of functions in libopensc (CVSS 3.9)
- CVE-2024-45616 — Libopensc: uninitialized values after incorrect check or usage of apdu response values in libopensc (CVSS 3.9)
- CVE-2024-45615 — Libopensc: pkcs15init: usage of uninitialized values in libopensc and pkcs15init (CVSS 3.9)
- CVE-2024-1454 — Opensc: memory use after free in authentic driver when updating token info (CVSS 3.4)
- CVE-2023-5992 — Opensc: side-channel leaks while stripping encryption pkcs#1 padding (CVSS 5.9)
- CVE-2023-4535 — Opensc: out-of-bounds read in myeid driver handling encryption using symmetric keys (CVSS 3.8)
- CVE-2023-40661 — Opensc: multiple memory issues with pkcs15-init (enrollment tool) (CVSS 6.4)
- CVE-2023-40660 — Opensc: potential pin bypass when card tracks its own login state (CVSS 6.6)
- CVE-2021-34193 — (CVSS 7.5)
- CVE-2023-2977 — (CVSS 7.1)
- CVE-2021-42782 — (CVSS 5.3)
- CVE-2021-42781 — (CVSS 5.3)
- CVE-2021-42780 — (CVSS 5.3)
- CVE-2021-42779 — (CVSS 5.3)