What’s Vulnerable › Vulnerabilities
CVE-2021-42782
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-18 · updated 2026-06-17
- Weakness: CWE-119
Description
Stack buffer overflow issues were found in Opensc before version 0.22.0 in various places that could potentially crash programs using the library.
Affected products
- Fedoraproject Fedora: 33
- OpenSC: before 0.22.0 — fixed in 0.22.0
How to fix
Upgrade to a fixed version: OpenSC 0.22.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2016448
- https://github.com/OpenSC/OpenSC/commit/1252aca9
- https://github.com/OpenSC/OpenSC/commit/456ac566
- https://github.com/OpenSC/OpenSC/commit/7114fb71
- https://github.com/OpenSC/OpenSC/commit/78cdab94
- https://github.com/OpenSC/OpenSC/commit/ae1cf0be
- https://lists.debian.org/debian-lts-announce/2023/06/msg00025.html
- https://security.gentoo.org/glsa/202209-03
- https://bugzilla.redhat.com/show_bug.cgi?id=2016448
- https://github.com/OpenSC/OpenSC/commit/1252aca9
- https://github.com/OpenSC/OpenSC/commit/456ac566
- https://github.com/OpenSC/OpenSC/commit/7114fb71
Get alerted when CVE-2021-42782 or the next vulnerability affects your stack