What’s Vulnerable › Vulnerabilities
CVE-2025-13763: Libopensc: opensc: multiple uses of uninitialized variable
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-23 · updated 2026-10-14
- Weakness: CWE-457
Description
Multiple uses of uninitialized variables were found in libopensc that may lead to information disclosure or application crash. An attack requires a crafted USB device or smart card that would present the system with specially crafted responses to the APDUs
Affected products
- OpenSC: before 0.27.0 — fixed in 0.27.0
- Red Hat Enterprise Linux 10: all versions
- Red Hat Enterprise Linux 7: all versions
- Red Hat Enterprise Linux 8: all versions
- Red Hat Enterprise Linux 9: all versions
How to fix
Upgrade to a fixed version: OpenSC 0.27.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-13763
- https://bugzilla.redhat.com/show_bug.cgi?id=2417581
- https://github.com/OpenSC/OpenSC/security/advisories/GHSA-2v44-fq35-98vv
- https://github.com/OpenSC/OpenSC/wiki/CVE-2025-13763
- https://github.com/OpenSC/OpenSC/security/advisories/GHSA-2v44-fq35-98vv
Get alerted when CVE-2025-13763 or the next vulnerability affects your stack