What’s Vulnerable › Vulnerabilities
CVE-2025-66215: OpenSC: Stack-buffer-overflow WRITE in card-oberthur
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-30 · updated 2026-06-17
- Weakness: CWE-121
Description
OpenSC is an open source smart card tools and middleware. Prior to version 0.27.0, an attacker with physical access to the computer at the time user or administrator uses a token can cause a stack-buffer-overflow WRITE in card-oberthur. The attack requires crafted USB device or smart card that would present the system with specially crafted responses to the APDUs. This issue has been patched in version 0.27.0.
Affected products
- OpenSC: before 0.27.0 — fixed in 0.27.0
How to fix
Upgrade to a fixed version: OpenSC 0.27.0. Check the vendor advisory for mitigations.
References
- https://github.com/OpenSC/OpenSC/commit/efd1d479832141bcf705c2f47655ada4d5f92f5d
- https://github.com/OpenSC/OpenSC/pull/3436
- https://github.com/OpenSC/OpenSC/security/advisories/GHSA-q5fc-cw56-hwp2
- https://github.com/OpenSC/OpenSC/wiki/CVE-2025-66215
Get alerted when CVE-2025-66215 or the next vulnerability affects your stack