What’s Vulnerable › Vulnerabilities
CVE-2024-1454: Opensc: memory use after free in authentic driver when updating token info
- Severity: low (CVSS 3.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-12 · updated 2026-06-17
- Weakness: CWE-416
Description
The use-after-free vulnerability was found in the AuthentIC driver in OpenSC packages, occuring in the card enrolment process using pkcs15-init when a user or administrator enrols or modifies cards. An attacker must have physical access to the computer system and requires a crafted USB device or smart card to present the system with specially crafted responses to the APDUs, which are considered high complexity and low severity. This manipulation can allow for compromised card management operations during enrolment.
Affected products
- Fedoraproject Fedora: 38, 39, 40
- OpenSC: before 0.25.0 — fixed in 0.25.0
- Red Hat Enterprise Linux: 7.0, 8.0, 9.0
How to fix
Upgrade to a fixed version: OpenSC 0.25.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2024-1454
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=64898
- https://bugzilla.redhat.com/show_bug.cgi?id=2263929
- https://github.com/OpenSC/OpenSC/commit/5835f0d4f6c033bd58806d33fa546908d39825c9
- https://access.redhat.com/security/cve/CVE-2024-1454
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=64898
- https://bugzilla.redhat.com/show_bug.cgi?id=2263929
- https://github.com/OpenSC/OpenSC/commit/5835f0d4f6c033bd58806d33fa546908d39825c9
- https://lists.debian.org/debian-lts-announce/2024/12/msg00026.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/OWIZ5ZLO5ECYPLSTESCF7I7PQO5X6ZSU/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RJI2FWLY24EOPALQ43YPQEZMEP3APPPI/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/UECKC7X4IM4YZQ5KRQMNBNKNOXLZC7RZ/
Get alerted when CVE-2024-1454 or the next vulnerability affects your stack