What’s Vulnerable › Vulnerabilities
CVE-2021-42781
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-18 · updated 2026-06-17
- Weakness: CWE-119
Description
Heap buffer overflow issues were found in Opensc before version 0.22.0 in pkcs15-oberthur.c that could potentially crash programs using the library.
Affected products
- Fedoraproject Fedora: 33
- OpenSC: before 0.22.0 — fixed in 0.22.0
- Red Hat Enterprise Linux: 7.0
How to fix
Upgrade to a fixed version: OpenSC 0.22.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2016439
- https://github.com/OpenSC/OpenSC/commit/05648b06
- https://github.com/OpenSC/OpenSC/commit/17d8980c
- https://github.com/OpenSC/OpenSC/commit/40c50a3a
- https://github.com/OpenSC/OpenSC/commit/5d4daf6c
- https://github.com/OpenSC/OpenSC/commit/cae5c71f
- https://lists.debian.org/debian-lts-announce/2023/06/msg00025.html
- https://security.gentoo.org/glsa/202209-03
- https://bugzilla.redhat.com/show_bug.cgi?id=2016439
- https://github.com/OpenSC/OpenSC/commit/05648b06
- https://github.com/OpenSC/OpenSC/commit/17d8980c
- https://github.com/OpenSC/OpenSC/commit/40c50a3a
Get alerted when CVE-2021-42781 or the next vulnerability affects your stack