What’s Vulnerable › Vulnerabilities
CVE-2024-45619: Libopensc: incorrect handling length of buffers or files in libopensc
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-03 · updated 2026-06-30
- Weakness: CWE-120
Description
A vulnerability was found in OpenSC, OpenSC tools, PKCS#11 module, minidriver, and CTK. An attacker could use a crafted USB Device or Smart Card, which would present the system with a specially crafted response to APDUs. When buffers are partially filled with data, initialized parts of the buffer can be incorrectly accessed.
Affected products
- OpenSC: before 0.26.0 — fixed in 0.26.0
- Red Hat Enterprise Linux: 7.0, 8.0, 9.0
How to fix
Upgrade to a fixed version: OpenSC 0.26.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2024-45619
- https://bugzilla.redhat.com/show_bug.cgi?id=2309288
- https://lists.debian.org/debian-lts-announce/2024/12/msg00026.html
Get alerted when CVE-2024-45619 or the next vulnerability affects your stack