What’s Vulnerable › Vulnerabilities
CVE-2025-66037: OpenSC: Out of Bounds vulnerability
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-30 · updated 2026-06-17
- Weakness: CWE-125
Description
OpenSC is an open source smart card tools and middleware. Prior to version 0.27.0, feeding a crafted input to the fuzz_pkcs15_reader harness causes OpenSC to perform an out-of-bounds heap read in the X.509/SPKI handling path. Specifically, sc_pkcs15_pubkey_from_spki_fields() allocates a zero-length buffer and then reads one byte past the end of that allocation. This issue has been patched in version 0.27.0.
Affected products
- OpenSC: before 0.27.0 — fixed in 0.27.0
How to fix
Upgrade to a fixed version: OpenSC 0.27.0. Check the vendor advisory for mitigations.
References
- https://github.com/OpenSC/OpenSC/security/advisories/GHSA-m58q-rmjm-mmfx
- https://github.com/OpenSC/OpenSC/wiki/CVE-2025-66037
Get alerted when CVE-2025-66037 or the next vulnerability affects your stack