What’s Vulnerable › Vulnerabilities
CVE-2021-34640: Securimage-WP-Fixed <= 3.5.4 Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The Securimage-WP-Fixed WordPress plugin is vulnerable to Reflected Cross-Site Scripting due to the use of $_SERVER['PHP_SELF'] in the ~/securimage-wp.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 3.5.4.
Affected products
- Drew Phillips Securimage-WP: through 3.5.4
References
- https://plugins.trac.wordpress.org/browser/securimage-wp-fixed/trunk/securimage-wp.php#L628
- https://www.wordfence.com/vulnerability-advisories/#CVE-2021-34640
- https://plugins.trac.wordpress.org/browser/securimage-wp-fixed/trunk/securimage-wp.php#L628
- https://www.wordfence.com/vulnerability-advisories/#CVE-2021-34640
Get alerted when CVE-2021-34640 or the next vulnerability affects your stack