What’s Vulnerable › Vulnerabilities
CVE-2021-42365: Asgaros Forums <= 1.15.13 Authenticated Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Asgaros Forums WordPress plugin is vulnerable to Stored Cross-Site Scripting due to insufficient escaping via the name parameter found in the ~/admin/tables/admin-structure-table.php file which allowed attackers with administrative user access to inject arbitrary web scripts, in versions up to and including 1.15.13. This affects multi-site installations where unfiltered_html is disabled for administrators, and sites where unfiltered_html is disabled.
Affected products
- Asgaros Forum: before 1.15.14 — fixed in 1.15.14
How to fix
Upgrade to a fixed version: Asgaros Forum 1.15.14. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2635143/asgaros-forum/trunk/admin/tables/admin-structure-table.php
- https://wordfence.com/vulnerability-advisories/#CVE-2021-42365
- https://plugins.trac.wordpress.org/changeset/2635143/asgaros-forum/trunk/admin/tables/admin-structure-table.php
- https://wordfence.com/vulnerability-advisories/#CVE-2021-42365
Get alerted when CVE-2021-42365 or the next vulnerability affects your stack