What’s Vulnerable › Vulnerabilities
CVE-2021-4374: WordPress Automatic Plugin <= 3.53.2 - Unauthenticated Arbitrary Options Update
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 16.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-07 · updated 2026-06-17
- Weakness: CWE-862
Description
The WordPress Automatic Plugin for WordPress is vulnerable to arbitrary options updates in versions up to, and including, 3.53.2. This is due to missing authorization and option validation in the process_form.php file. This makes it possible for unauthenticated attackers to arbitrarily update the settings of a vulnerable site and ultimately compromise the entire site.
Affected products
- ValvePress WordPress Automatic Plugin: through 3.53.2
References
- https://blog.nintechnet.com/critical-vulnerability-fixed-in-wordpress-automatic-plugin/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d0567dc8-7a4c-42f4-bf45-f31a8efaa354?source=cve
- https://blog.nintechnet.com/critical-vulnerability-fixed-in-wordpress-automatic-plugin/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d0567dc8-7a4c-42f4-bf45-f31a8efaa354?source=cve
Get alerted when CVE-2021-4374 or the next vulnerability affects your stack