What’s Vulnerable › Vulnerabilities
CVE-2021-4436: 3DPrint Lite < 1.9.1.5 - Unauthenticated Arbitrary File Upload
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-05 · updated 2026-06-17
- Weakness: CWE-434
Description
The 3DPrint Lite WordPress plugin before 1.9.1.5 does not have any authorisation and does not check the uploaded file in its p3dlite_handle_upload AJAX action , allowing unauthenticated users to upload arbitrary file to the web server. However, there is a .htaccess, preventing the file to be accessed on Web servers such as Apache.
Affected products
- fuzzoid 3DPrint Lite: before 1.9.1.5 — fixed in 1.9.1.5
How to fix
Upgrade to a fixed version: fuzzoid 3DPrint Lite 1.9.1.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c46ecd0d-a132-4ad6-b936-8acde3a09282/
- https://wpscan.com/vulnerability/c46ecd0d-a132-4ad6-b936-8acde3a09282/
Get alerted when CVE-2021-4436 or the next vulnerability affects your stack