What’s Vulnerable › Vulnerabilities
CVE-2021-4445: Premium Addons for Elementor <= 4.5.1 - Authenticated (Subscriber+) Limited Arbitrary Option Update
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-862
Description
The Premium Addons for Elementor plugin for WordPress is vulnerable to Arbitrary Option Updates in versions up to, and including, 4.5.1. This is due to missing capability and nonce checks in the pa_dismiss_admin_notice AJAX action. This makes it possible for authenticated subscriber+ attackers to change arbitrary options with a restricted value of 1 on vulnerable WordPress sites.
Affected products
- leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets: before 4.5.2 — fixed in 4.5.2
How to fix
Upgrade to a fixed version: leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets 4.5.2. Check the vendor advisory for mitigations.
References
- https://ithemes.com/blog/wordpress-vulnerability-report-september-2021-part-2/#ib-toc-anchor-2
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2590819%40premium-addons-for-elementor&new=2590819%40premium-addons-for-elementor&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/premium-addons-for-elementor/
- https://wpscan.com/vulnerability/2e5b3608-1dfc-468f-b3ae-12ce7c25ee6c
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cffb26bc-3d3f-4593-bb36-d2abcd67861e?source=cve
Get alerted when CVE-2021-4445 or the next vulnerability affects your stack