What’s Vulnerable › Vulnerabilities
CVE-2022-0411: Asgaros Forum < 2.0.0 - Subscriber+ Blind SQL Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-89
Description
The Asgaros Forum WordPress plugin before 2.0.0 does not sanitise and escape the post_id parameter before using it in a SQL statement via a REST route of the plugin (accessible to any authenticated user), leading to a SQL injection
Affected products
- Asgaros Forum: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Asgaros Forum 2.0.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2669226/asgaros-forum
- https://wpscan.com/vulnerability/35272197-c973-48ad-8405-538bfbafa172
- https://plugins.trac.wordpress.org/changeset/2669226/asgaros-forum
- https://wpscan.com/vulnerability/35272197-c973-48ad-8405-538bfbafa172
Get alerted when CVE-2022-0411 or the next vulnerability affects your stack