What’s Vulnerable › Vulnerabilities
CVE-2022-1589: Change wp-admin Login < 1.1.0 - Unauthenticated Arbitrary Settings Update
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-30 · updated 2026-06-17
- Weakness: CWE-352
Description
The Change wp-admin login WordPress plugin before 1.1.0 does not properly check for authorisation and is also missing CSRF check when updating its settings, which could allow unauthenticated users to change the settings. The attacked could also be performed via a CSRF vector
Affected products
- Change wp-admin login: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: Change wp-admin login 1.1.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/257f9e14-4f43-4852-8384-80c15d087633
- https://wpscan.com/vulnerability/257f9e14-4f43-4852-8384-80c15d087633
Get alerted when CVE-2022-1589 or the next vulnerability affects your stack