What’s Vulnerable › Vulnerabilities
CVE-2022-1591: WordPress Ping Optimizer < 2.35.1.3.0 - Arbitrary Settings Update via CSRF
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-19 · updated 2026-06-17
- Weakness: CWE-352
Description
The WordPress Ping Optimizer WordPress plugin before 2.35.1.3.0 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack
Affected products
- WordPress Ping Optimizer: before 2.35.1.3.0 — fixed in 2.35.1.3.0
How to fix
Upgrade to a fixed version: WordPress Ping Optimizer 2.35.1.3.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b1a52c7e-3422-40dd-af5a-ea4c622a87aa
- https://wpscan.com/vulnerability/b1a52c7e-3422-40dd-af5a-ea4c622a87aa
Get alerted when CVE-2022-1591 or the next vulnerability affects your stack