What’s Vulnerable › Vulnerabilities
CVE-2022-2446: WP Editor <= 1.2.9 - Authenticated (Admin+) PHAR Deserialization
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-13 · updated 2026-06-17
- Weakness: CWE-502
Description
The WP Editor plugin for WordPress is vulnerable to deserialization of untrusted input via the 'current_theme_root' parameter in versions up to, and including 1.2.9. This makes it possible for authenticated attackers with administrative privileges to call files using a PHAR wrapper that will deserialize and call arbitrary PHP Objects that can be used to perform a variety of malicious actions granted a POP chain is also present. It also requires that the attacker is successful in uploading a file with the serialized payload.
Affected products
- benjaminprojas WP Editor: before 1.2.9.1 — fixed in 1.2.9.1
How to fix
Upgrade to a fixed version: benjaminprojas WP Editor 1.2.9.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3151053/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f3555702-4427-4569-8fd6-f84113593e9d?source=cve
Get alerted when CVE-2022-2446 or the next vulnerability affects your stack