What’s Vulnerable › Vulnerabilities
CVE-2022-2654: Classima < 2.1.11 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Classima WordPress theme before 2.1.11 and some of its required plugins (Classified Listing before 2.2.14, Classified Listing Pro before 2.0.20, Classified Listing Store & Membership before 1.4.20 and Classima Core before 1.10) do not escape a parameter before outputting it back in attributes, leading to Reflected Cross-Site Scripting
Affected products
- RadiusTheme Classified Listing: before 2.0.20; before 2.2.14 — fixed in 2.0.20, 2.2.14
- RadiusTheme Classified Listing Store & Membership: before 1.4.20 — fixed in 1.4.20
- RadiusTheme Classima: before 2.1.11 — fixed in 2.1.11
- RadiusTheme Classima Core: before 1.10 — fixed in 1.10
How to fix
Upgrade to a fixed version: RadiusTheme Classified Listing 2.0.20, 2.2.14; RadiusTheme Classified Listing Store & Membership 1.4.20; RadiusTheme Classima 2.1.11; RadiusTheme Classima Core 1.10. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/845f44ca-f572-48d7-a19a-89cace0b8993
- https://wpscan.com/vulnerability/845f44ca-f572-48d7-a19a-89cace0b8993
Get alerted when CVE-2022-2654 or the next vulnerability affects your stack