What’s Vulnerable › Vulnerabilities
CVE-2022-3334: Easy WP SMTP < 1.5.0 - Admin+ PHP Objection Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-31 · updated 2026-06-17
- Weakness: CWE-502
Description
The Easy WP SMTP WordPress plugin before 1.5.0 unserialises the content of an imported file, which could lead to PHP object injection issue when an admin import (intentionally or not) a malicious file and a suitable gadget chain is present on the blog.
Affected products
- WPecommerce, Alexanderfoxc Easy WP SMTP: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: WPecommerce, Alexanderfoxc Easy WP SMTP 1.5.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0e735502-eaa2-4047-949e-bc8eb6b39fc9
- https://wpscan.com/vulnerability/0e735502-eaa2-4047-949e-bc8eb6b39fc9
Get alerted when CVE-2022-3334 or the next vulnerability affects your stack