What’s Vulnerable › Vulnerabilities
CVE-2022-4106: Wholesale Market for WooCommerce < 1.0.7 - Unauthenticated Arbitrary File Download
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-19 · updated 2026-06-17
- Weakness: CWE-552
Description
The Wholesale Market for WooCommerce WordPress plugin before 1.0.7 does not have authorisation check, as well as does not validate user input used to generate system path, allowing unauthenticated attackers to download arbitrary file from the server.
Affected products
- Wholesale Market for WooCommerce: before 1.0.7 — fixed in 1.0.7
How to fix
Upgrade to a fixed version: Wholesale Market for WooCommerce 1.0.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b60a0d3d-148f-4e9b-baee-7332890804ed
- https://wpscan.com/vulnerability/b60a0d3d-148f-4e9b-baee-7332890804ed
Get alerted when CVE-2022-4106 or the next vulnerability affects your stack