What’s Vulnerable › Vulnerabilities
CVE-2022-4108: Wholesale Market for WooCommerce < 1.0.8 - Admin+ Arbitrary File Download
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-19 · updated 2026-06-17
Description
The Wholesale Market for WooCommerce WordPress plugin before 1.0.8 does not validate user input used to generate system path, allowing high privilege users such as admin to download arbitrary file from the server even when they should not be able to (for example in multisite)
Affected products
- Wholesale Market for WooCommerce: before 1.0.8 — fixed in 1.0.8
How to fix
Upgrade to a fixed version: Wholesale Market for WooCommerce 1.0.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9d1770df-91f0-41e3-af0d-522ae4e62470
- https://wpscan.com/vulnerability/9d1770df-91f0-41e3-af0d-522ae4e62470
Get alerted when CVE-2022-4108 or the next vulnerability affects your stack