What’s Vulnerable › Vulnerabilities
CVE-2022-4363: Wholesale Market <= 2.2.2 - Settings Update via CSRF
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-16 · updated 2026-06-17
- Weakness: CWE-352
Description
The Wholesale Market WordPress plugin before 2.2.2, Wholesale Market for WooCommerce WordPress plugin before 2.0.1 have a flawed CSRF check when updating their settings, which could allow attackers to make a logged in admin update them via a CSRF attack
Affected products
- Wholesale Market: before 2.2.2 — fixed in 2.2.2
- Wholesale Market for WooCommerce: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: Wholesale Market 2.2.2; Wholesale Market for WooCommerce 2.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-4363 or the next vulnerability affects your stack