What’s Vulnerable › Vulnerabilities
CVE-2022-4653: Greenshift – animation and page builder blocks < 4.8.9 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-16 · updated 2026-06-17
Description
The Greenshift WordPress plugin before 4.8.9 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Affected products
- wpsoul Greenshift – animation and page builder blocks: before 4.8.9 — fixed in 4.8.9
How to fix
Upgrade to a fixed version: wpsoul Greenshift – animation and page builder blocks 4.8.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/fa44ed44-9dac-4b4f-aaa3-503b76034578
- https://wpscan.com/vulnerability/fa44ed44-9dac-4b4f-aaa3-503b76034578
Get alerted when CVE-2022-4653 or the next vulnerability affects your stack