What’s Vulnerable › Products
wpsoul Greenshift – animation and page builder blocks vulnerabilities
23 known vulnerabilities, 0 confirmed exploited in the wild (CISA KEV), 16 published in the last 12 months.
Check whether your wpsoul Greenshift – animation and page builder blocks version is affected
Latest wpsoul Greenshift – animation and page builder blocks vulnerabilities
- CVE-2026-107629 — Greenshift <= 13.2.1 - Unauthenticated Stored DOM-Based Cross-Site Scripting via Comment Content via Split Text innerText (CVSS 5.4)
- CVE-2026-107627 — Greenshift <= 13.2.1 - Unauthenticated Stored DOM-Based Cross-Site Scripting via Comment Content via Nested Latest Comments Block (CVSS 5.4)
- CVE-2026-93880 — Greenshift <= 13.2.0 - Reflected Cross-Site Scripting via '{{GET:}}' Dynamic Placeholder (CVSS 6.1)
- CVE-2026-83544 — Greenshift < 13.2.0 - Contributor+ Stored XSS via Block Animation customProps Attribute (CVSS 6.8)
- CVE-2026-83543 — Greenshift < 13.2.0 - Contributor+ SSRF via get-csv-to-json REST Endpoint (CVSS 4.1)
- CVE-2026-5092 — Greenshift <= 12.8.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via Data URI (CVSS 6.4)
- CVE-2026-5093 — Greenshift <= 12.8.9 - Authenticated (Contributor+) Theme Settings Modification via 'gspb_update_global_wp_settings' (CVSS 4.3)
- CVE-2026-4895 — Greenshift <= 12.8.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via disablelazy Attribute (CVSS 6.4)
- CVE-2026-2371 — Greenshift <= 12.8.3 - Missing Authorization to Unauthenticated Private Reusable Block Disclosure via 'gspb_el_reusable_load' (CVSS 5.3)
- CVE-2026-2589 — Greenshift – animation and page builder blocks <= 12.8.3 - Unauthenticated Sensitive Information Exposure via Settings Backup (CVSS 5.3)
- CVE-2026-2593 — Greenshift – animation and page builder blocks <= 12.8.5 - Authenticated (Contributor+) Stored Cross-Site Scripting (CVSS 6.4)
- CVE-2026-1927 — GreenShift - Animation and Page Builder Blocks <= 12.6 - Missing Authorization to Authenticated (Subscriber+) Information Disclosure of AI API Keys and Stored Cross-Site Scripting via custom_css (CVSS 5.4)
- CVE-2025-11841 — Greenshift – animation and page builder blocks <= 12.2.7 - Authenticated (Contributor+) Stored Cross-Site Scripting via Chart Data Attributes (CVSS 6.4)
- CVE-2025-57884 — WordPress Greenshift Plugin <= 12.1.1 - Broken Access Control Vulnerability (CVSS 4.3)
- CVE-2025-49301 — WordPress Greenshift plugin <= 11.5.5 - Cross Site Scripting (XSS) Vulnerability (CVSS 6.5)
- CVE-2025-30873 — WordPress Greenshift plugin <= 11.0.2 - Cross Site Scripting (XSS) vulnerability (CVSS 5.4)
- CVE-2022-4974 — Freemius SDK <= 2.4.2 - Missing Authorization Checks (CVSS 6.3)
- CVE-2024-44005 — WordPress Greenshift plugin <= 9.3.7 - Cross Site Scripting (XSS) vulnerability (CVSS 5.4)
- CVE-2024-35765 — WordPress Greenshift – animation and page builder blocks plugin <= 8.8.9.1 - Cross Site Scripting (XSS) vulnerability (CVSS 5.4)
- CVE-2023-6636 — Greenshift – animation and page builder blocks <= 7.6.2 - Authenticated (Administrator+) Arbitrary File Upload (CVSS 7.2)
- CVE-2023-22707 — WordPress Greenshift – animation and page builder blocks Plugin <= 4.9.9 is vulnerable to Cross Site Scripting (XSS) (CVSS 5.4)
- CVE-2023-0378 — Greenshift < 5.0 - Contributor+ Stored XSS (CVSS 5.4)
- CVE-2022-4653 — Greenshift – animation and page builder blocks < 4.8.9 - Contributor+ Stored XSS via Shortcode (CVSS 5.4)