What’s Vulnerable › Vulnerabilities
CVE-2023-0378: Greenshift < 5.0 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-21 · updated 2026-06-17
Description
The Greenshift WordPress plugin before 5.0 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- wpsoul Greenshift – animation and page builder blocks: before 5.0 — fixed in 5.0
How to fix
Upgrade to a fixed version: wpsoul Greenshift – animation and page builder blocks 5.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3313cc05-2267-4d93-a8a8-2c0701c21f66
- https://wpscan.com/vulnerability/3313cc05-2267-4d93-a8a8-2c0701c21f66
Get alerted when CVE-2023-0378 or the next vulnerability affects your stack