What’s Vulnerable › Vulnerabilities
CVE-2023-2572: Survey Maker < 3.4.7 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-05 · updated 2026-10-28
Description
The Survey Maker WordPress plugin before 3.4.7 does not escape some parameters before outputting them back in attributes, leading to Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- Ays Pro Survey Maker: before 3.4.7 — fixed in 3.4.7
How to fix
Upgrade to a fixed version: Ays Pro Survey Maker 3.4.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2f7fe6e6-c3d0-4e27-8222-572d7a420153
- https://wpscan.com/vulnerability/2f7fe6e6-c3d0-4e27-8222-572d7a420153
Get alerted when CVE-2023-2572 or the next vulnerability affects your stack